Polaris Pro Riders
Sign up Calendar Latest Topics
 
 
 


Reply
  Author   Comment  
Redline345

Registered:
Posts: 3
Reply with quote  #1 
Ok I just got my 08 outlaw 540bb mxr running and it just won't go with anything over 3/8 throttle it just bogs and sounds like it has rolling anti-lag. I bored it from a 450 to 540, race ported head, stage 4 thumper racing cam, 12.5:1 compression, and 42mm bore on the carb. I live at 3800ft elevation, 85-90 degrees average, with about 30% humidity average if that would help at all. It idles fine and rides fine with anything lower than 3/8 throttle
polaris bob

Avatar / Picture

Supporting Member
Registered:
Posts: 608
Reply with quote  #2 
What carb are you using? What intake? Which exhaust?

Details, details.......

__________________
2003 Polaris Predator / 2004 KTM 525 exc 6 speed motor.

570 Thumper Racing kit w/ 12.5 - 1 CP piston. Head ported by Thumper Racing w/ new intake seats done by Pro-1 racing. Stage 5 cam (Custom design by Thumper Racing). AC bearing mod. Oil system mod by DJH. KW valves (stock size). * #100 CDI dirt bike CDI. 42 mm FCR carb by Walt/Fast64ranchero. (SX carb = No TPS). Trail Tech -10 oz flywheel. (Stock is 30 oz/ trail tech = 21 Oz's)
Mino water pump. Full flow set up, no T-stat. PB Oil cooler. Custom modded intake. Uni filter/ D2 Moto adapter on a modded Predator intake tube.
KTM Bill modded CT racing full exhaust system. Tusk Clutch kit. Honda thumb throttle. Snyder Motorsports adjustable upper A-arms. PP Billet front hubs W/ DLR tapered roller bearings. Custom modded fox suspension. Hidden comfort camo seat cover on a modded stock seat.
Redline345

Registered:
Posts: 3
Reply with quote  #3 
Well its the stock fcr mx carb thats been bored from 39mm to 42mm, stock airbox, and stock header with motoworks sr4carbon exhaust
TxOutlawRider

Registered:
Posts: 1,674
Reply with quote  #4 
I'm gonna start with an easy question, is your accelerator pump working?
__________________
2007 Outlaw IRS

"Outlaws are the Chuck Norris of the quad world."
Redline345

Registered:
Posts: 3
Reply with quote  #5 
Yes I believe so, its a completely rebuilt carb with all new upgraded parts in it. If it may help I went out on my first ride after my break in today with full range of throttle, it seemed to suffer when I was just cruising and in the high rpms of 4th and 5th it started cutting out a little bit.
TxOutlawRider

Registered:
Posts: 1,674
Reply with quote  #6 
Quote:
Originally Posted by TxOutlawRider
I'm gonna start with an easy question, is your accelerator pump working?

__________________
2007 Outlaw IRS

"Outlaws are the Chuck Norris of the quad world."
TxOutlawRider

Registered:
Posts: 1,674
Reply with quote  #7 
Try raising the needle a notch and see if it gets better.
__________________
2007 Outlaw IRS

"Outlaws are the Chuck Norris of the quad world."
Previous Topic | Next Topic
Print
Reply

Quick Navigation:

Easily create a Forum Website with Website Toolbox.