Polaris Pro Riders
Sign up Calendar Latest Topics
 
 
 


Reply
  Author   Comment  
Team Bricktucky

Avatar / Picture

Registered:
Posts: 2,071
Reply with quote  #1 
I bought a new pulsar coil and stator ,Ive checked all the wire connections and wires . I have a oil cooler set up and engine ice. I use rotella t 15w-40. My jetting is spot on . I took out my HID lights To make sure that has nothing to do wit it.
Im out of Ideas, and I do not want to keep buying pulsar coils. what gives here?does the outlaw have a cuircut breaker? It kinda does the same thing the predator use to do when the breaker would go bad.

I got to get this figured out out, I plan on taking the 525 to glamis on oct 23 to nov 1st.  am I gunna need to pack several pulsar coils?
LEOGM5150

Avatar / Picture

SITE OWNER
Registered:
Posts: 15,429
Reply with quote  #2 
here are the only circuit breakers in the 525 outlaw service manual wiring diagram.





__________________
FROM: POWELL WYOMING USA

MY GREATEST FEAR IS THAT WHEN I DIE MY WIFE WILL SELL MY TOYS FOR WHAT I TOLD HER I HAVE INTO THEM...

2014 POLARIS RZR 4 900 EPS
2012 POLARIS RZR 4 900 XP
2008 POLARIS RZR 800
2008 POLARIS OUTLAW 525S LE
2007 POLARIS OUTLAW 525 IRS
2000 400 RCR TWO STROKE SCRAMBLER
2001 400 TWO STROKE SCRAMBLER
2005 SKI DOO 1000 TWO STROKE SAND SLED
Team Bricktucky

Avatar / Picture

Registered:
Posts: 2,071
Reply with quote  #3 

so those fuse looking thingys are the circuit breakers? hummm maybe I'll buy new ones just to be sure. another thing I thought of, that maybe a cause to my problem could be the TPS wire/plug. I took the oem throttle off so I unpluged the TPS wire and just tucked it under the plastics. Maybe mud/water has shorted it out,or maybe the wire has rubbed. I look into it today/tonight.

LEOGM5150

Avatar / Picture

SITE OWNER
Registered:
Posts: 15,429
Reply with quote  #4 
i suspect it is the tps getting wet or corroded. next guess is a circuit breaker.
__________________
FROM: POWELL WYOMING USA

MY GREATEST FEAR IS THAT WHEN I DIE MY WIFE WILL SELL MY TOYS FOR WHAT I TOLD HER I HAVE INTO THEM...

2014 POLARIS RZR 4 900 EPS
2012 POLARIS RZR 4 900 XP
2008 POLARIS RZR 800
2008 POLARIS OUTLAW 525S LE
2007 POLARIS OUTLAW 525 IRS
2000 400 RCR TWO STROKE SCRAMBLER
2001 400 TWO STROKE SCRAMBLER
2005 SKI DOO 1000 TWO STROKE SAND SLED
polaris bob

Avatar / Picture

Supporting Member
Registered:
Posts: 604
Reply with quote  #5 
Those should not be circuit breakers, they should be fuses.

By un-plugging your TPS you have forced the ign to go to full advance at all times. This can cause your motor to run hotter at all throttle positions because of the advance curve built into the ign box.

One of my next last mods is to install a 41 MM FCR with a TPS so I can play with my timing curves a bit.

This is one reason I came out with my oil cooler back in the day, because my motor runs hotter because of the timing advance.

It also is the reason I ride with a 50 /50 mix of race fuel and pump premium. The advance can get a little too advanced at part throttle cruise conditions. She sometimes tends to spark knock just a tad. A bit of race fuel fixed that problem for me.


Matt, give me a call when you have the chance. I'll see if we can't get the issue figured out.




__________________
2003 Polaris Predator / 2004 KTM 525 exc 6 speed motor.

570 Thumper Racing kit w/ 12.5 - 1 CP piston. Head ported by Thumper Racing w/ new intake seats done by Pro-1 racing. Stage 5 cam (Custom design by Thumper Racing). AC bearing mod. Oil system mod by DJH. KW valves (stock size). * #100 CDI dirt bike CDI. 42 mm FCR carb by Walt/Fast64ranchero. (SX carb = No TPS). Trail Tech -10 oz flywheel. (Stock is 30 oz/ trail tech = 21 Oz's)
Mino water pump. Full flow set up, no T-stat. PB Oil cooler. Custom modded intake. Uni filter/ D2 Moto adapter on a modded Predator intake tube.
KTM Bill modded CT racing full exhaust system. Tusk Clutch kit. Honda thumb throttle. Snyder Motorsports adjustable upper A-arms. PP Billet front hubs W/ DLR tapered roller bearings. Custom modded fox suspension. Hidden comfort camo seat cover on a modded stock seat.
Team Bricktucky

Avatar / Picture

Registered:
Posts: 2,071
Reply with quote  #6 
hey thanks guys for your help.Good info there bob, I never knew that.
Here is my update. the tps wires seem fine so I cleaned the plug up blew it out and liquid taped it the wrapped it with electric tape.However ,I do not think that was the issue, I also believe that the fuses/circuit breakes are not the issue .
Here is what I found---The whole time Ive been having this problem ,I felt it was a fuel issue or spark, so Ive been asking myself what has changed and when did it start happing. I then rememebered that I bought a team alba fuel cap for a predator and put a moose orange vent on it. I also plugged the tanl vent because of the vented fuel cap.
Well wouldn't know it? the vent is not working right. I couldn't blow thought the cap. I would have never figured that to be a problem because it is new. I blew compressed air though the vent and i can now blow though it.However the vent/valve doeson't seem right. all the vents I have had ,I could flick my finger against it and here the rattle of the vale inside. This moose valve will not do that. I feel it gets stuck closed, then the fuel will not flow fast enough or at all at high speeds.

So I think I call moose to try to get a new one, and try this out before I go any deeper. I think Im sure this is the problem.
LEOGM5150

Avatar / Picture

SITE OWNER
Registered:
Posts: 15,429
Reply with quote  #7 
glad you found it. please let us know how it turns out for sure.
__________________
FROM: POWELL WYOMING USA

MY GREATEST FEAR IS THAT WHEN I DIE MY WIFE WILL SELL MY TOYS FOR WHAT I TOLD HER I HAVE INTO THEM...

2014 POLARIS RZR 4 900 EPS
2012 POLARIS RZR 4 900 XP
2008 POLARIS RZR 800
2008 POLARIS OUTLAW 525S LE
2007 POLARIS OUTLAW 525 IRS
2000 400 RCR TWO STROKE SCRAMBLER
2001 400 TWO STROKE SCRAMBLER
2005 SKI DOO 1000 TWO STROKE SAND SLED
Team Bricktucky

Avatar / Picture

Registered:
Posts: 2,071
Reply with quote  #8 
 MY OUTLAW WAS AWESOME THIS WEEKEND!!!! I guess the stupid vent was my issue this whole time. well at least I have an extra pulsar coil.

I still have to pull the carb off an fix the ap. I think something is wrong . at the end of the day on sunday I was getting a stumble when I'd get on the gas, almost like a miss fire,studder. I think it might be the ap timing or maybe the o-ring mod broke.  Its not bad but it's not right so i got to get in there.
Deadman

Avatar / Picture

Moderator
Registered:
Posts: 2,905
Reply with quote  #9 
I have broke 3 O-rings, but hey its better than breaking a real Rubber!   

__________________
2012 Renegade 1000 X XC!
Team Bricktucky

Avatar / Picture

Registered:
Posts: 2,071
Reply with quote  #10 
Yeah
I think I'll wire it this time, the rubber looks wooped on the ap. I got a replacement.
drtrider145

Registered:
Posts: 88
Reply with quote  #11 

what is the O-ring mod?

LEOGM5150

Avatar / Picture

SITE OWNER
Registered:
Posts: 15,429
Reply with quote  #12 
it is a mod to help with the ap squirt improving throttle response.


__________________
FROM: POWELL WYOMING USA

MY GREATEST FEAR IS THAT WHEN I DIE MY WIFE WILL SELL MY TOYS FOR WHAT I TOLD HER I HAVE INTO THEM...

2014 POLARIS RZR 4 900 EPS
2012 POLARIS RZR 4 900 XP
2008 POLARIS RZR 800
2008 POLARIS OUTLAW 525S LE
2007 POLARIS OUTLAW 525 IRS
2000 400 RCR TWO STROKE SCRAMBLER
2001 400 TWO STROKE SCRAMBLER
2005 SKI DOO 1000 TWO STROKE SAND SLED
Previous Topic | Next Topic
Print
Reply

Quick Navigation:

Easily create a Forum Website with Website Toolbox.