Polaris Pro Riders
Sign up Calendar Latest Topics
 
 
 


Reply
  Author   Comment  
03predatorx

Registered:
Posts: 9
Reply with quote  #1 
I'm new to site and new to the predator I don't know if someone can point me in the right direction I'm going nuts hahah....to start I just bought the quad a few weeks ago and it would rev good has plenty of power motor is quiet but when it sits there and idles it will idle for a little bit then just puff out the carb and shut off but start right back up...so I took the tank off cleaned it, it was a little dirty nothing crazy. Pulled the carb off and all jets out cleaned them with carb cleaner and air adjusted the air/fuel screw to 2.5 turns took the slide out and the clip was on the very bottom grove moved it up to the 3rd grove seemed to idle better but wouldn't rev, took it back apart moved it to the 2nd grove from the bottom, starts right up and revs but does the same thing at idle ???? I'm lost the pred does have a full hmf and pure Polaris open air box with uni filter any help is greatly appreciated! Thanks in advance
jaznackie

Registered:
Posts: 45
Reply with quote  #2 
My 2005 was doing something very similar. If I turned it off it would start right back up but if it died I would have to wait just a minute and it would start up again. As time went on it got to where I would have to put effort into keeping it running at times and other times after a short ride it would be idoling real high.  We never did pinpoint exactly what the cause was. I finally just replaced the carb with one off of a Honda TRX450, ditched the fuel pump & went to gravity and after some adjustments to get jetting right I have no problem. Point being it is likely the Carb and if I had just swapt it out to begin with I would have spent a lot more time riding and less time trying to figure out what was wrong with my bike[party0006]
03predatorx

Registered:
Posts: 9
Reply with quote  #3 
Thank you for the the reply has I know it's driving me up a wall I just wanna ride the damn thing lol.. I have been all through the wiring and all through the carb and still no results I may try new starter jet main jet and pilot jet... I don't know what jets are in it now but it's running super rich. That's my next resort is the trx450 pumper carb didn't really wanna have to spend the money on cables and whatnot but I may have no other options unless someone else can shed some light on the issue
jaznackie

Registered:
Posts: 45
Reply with quote  #4 
Before I changed the carb I had problems with the power switch so I thought my issue could have been electrical at one point. I had replaced the battery and the CDI box, tried several fuel pumps then I took out both the circuit breakers ( which were both in very bad shape) and put in fusible links. I wired my hid lights straight to the battery to rule those out as a problem. Switched from fuel pump to gravity feed and adjusted valves although I know that wasn't the problem I did it anyway. still the bike would idol for about 5-10 minutes then just die. I spent two trips at the dunes trying to figure out the problem and then I gave up. I will tell you I got a pumper carb off eBay for around $80 and got a rebuild kit for it for $20. I had purchased a Honda throttle cable but I ended up not using it as I was able to use my original cable and I ordered a couple of main jets to try out cuz I am to cheap to take my bike in and pay them to jet it for me. Good luck. If you figure it out let me know cuz i never did
jaznackie

Registered:
Posts: 45
Reply with quote  #5 
Forgot to mention that in between all of this I pulled my carb out and soaked it and cleaned it really good but didn't make a bit of difference either
03predatorx

Registered:
Posts: 9
Reply with quote  #6 
I think I'm just go that route the pumper carb is prior 04 models correct ? And did yours slide in your intake boot?
jaznackie

Registered:
Posts: 45
Reply with quote  #7 
My bike is 05TLD with the original intake and I had no problem getting it to slide on. Yes 04 and previous are the pumper carbs. I ordered mine from earlg0tcha used atv and dirt bike parts on eBay
flextx500

Registered:
Posts: 25
Reply with quote  #8 
How does it start when it's cold.  I know you said it will start right back up when warm, but I'm curious as to how it starts the first time out that day.
jaznackie

Registered:
Posts: 45
Reply with quote  #9 
Quote:
Originally Posted by flextx500
How does it start when it's cold.  I know you said it will start right back up when warm, but I'm curious as to how it starts the first time out that day.
jaznackie

Registered:
Posts: 45
Reply with quote  #10 
Not sure if you are asking me but my bike started right up every time even when it was cold. If I did not turn it off and it died on its own I would have to wait a minute then it would start again
03predatorx

Registered:
Posts: 9
Reply with quote  #11 
Mine fires right up all the time first time of the day with choke on fires right up and idles it's when u take the choke off it doesn't want to idle just puffs out the carb and shuts off it also won't rev to the limiter I noticed yesterday
flextx500

Registered:
Posts: 25
Reply with quote  #12 
Is it still the stock CDI box?
flextx500

Registered:
Posts: 25
Reply with quote  #13 

Sorry, the question was for the OP.

flextx500

Registered:
Posts: 25
Reply with quote  #14 
Does it still have the stock CDI box?
03predatorx

Registered:
Posts: 9
Reply with quote  #15 
Yes as far as I know stock cdi box
Dunph

Avatar / Picture

Moderator
Registered:
Posts: 2,277
Reply with quote  #16 
did you try 2.75/3 turns out? also check the diaphragm for pin holes and check the point of the needle. i am currently running a pumper but i never really had an issue with the stock cv other than it was dirty. also try a shim/washer under the clip
__________________
06 Outlaw 558
15 sportsman 850 sp
02 scrammy 400
2016 2500hd
2003 GMC Sierra 1500hd Quadrasteer Yes i know my rear wheels are crooked! http://www.youtube.com/user/dustinwpearce
Commi-chusetts
03predatorx

Registered:
Posts: 9
Reply with quote  #17 
Thanks for the reply dunph ! I have it he pilot screw set at 2.75 turns out been all through the carb except actually pulling the floats out ...I inspected the diaphram no holes cleaned all three jets and blasted the carb out with carb and choke cleaner same results ... It has a washer under the e clip on the needle which I have set at 2nd grove from the bottom I'm completely lost with it, it also leaks fuel out the overflow on the bottom of the carb.. It's got me stumped and I've rebuilt plenty of engines on other quads so I do have a good bit of mechanical knowledge
03predatorx

Registered:
Posts: 9
Reply with quote  #18 
Update I tore the carb apart again went through all the jets and none are plugged also removed the float assembly and the float needle was caked with junk cleaned it all up cleaned the gas tank again and still pops and shuts off at idle someone pretty pretty please shed some light
Dunph

Avatar / Picture

Moderator
Registered:
Posts: 2,277
Reply with quote  #19 
Ok. Let's check some easy stupid things. Pop the cover off of the throttle and check to make sure that those two contacts are not touching at idle. Next try to bypass the fuel pump. Go directly from the gas tank to the carb and plug the vacuum line from the head. I'm still worried that it's leaking from the overflow. Again try something stupid and check to make sure the drain is shut. If not, that sounds like an issue with the float. Take the float out and put it in some soapy water and submerge it see if you see any bubbles. If not, it may still be no good. Also check the nubbin attached to the float that plugs the fuel line. It may be worn. I've had that happen to me a couple times. Always check the easy stupid stuff because that's what usually stumps me
__________________
06 Outlaw 558
15 sportsman 850 sp
02 scrammy 400
2016 2500hd
2003 GMC Sierra 1500hd Quadrasteer Yes i know my rear wheels are crooked! http://www.youtube.com/user/dustinwpearce
Commi-chusetts
03predatorx

Registered:
Posts: 9
Reply with quote  #20 
I actually just sold it yesterday I couldn't take it any more driving me nuts !! Some one got a decent deal on a freshly rebuilt 05 predator . I always was more into bikes so I bought a 2006 yz250f... I thank you guys a lot for trying to help me chase down the problem but I was in over my head I guess
Dunph

Avatar / Picture

Moderator
Registered:
Posts: 2,277
Reply with quote  #21 
happy to help. don't be a stranger!
__________________
06 Outlaw 558
15 sportsman 850 sp
02 scrammy 400
2016 2500hd
2003 GMC Sierra 1500hd Quadrasteer Yes i know my rear wheels are crooked! http://www.youtube.com/user/dustinwpearce
Commi-chusetts
03predatorx

Registered:
Posts: 9
Reply with quote  #22 
I definitely won't be ill have another predator/outlaw before too long and again thanks for all the advice guys
Previous Topic | Next Topic
Print
Reply

Quick Navigation:

Easily create a Forum Website with Website Toolbox.